OMV auf Raspberry Pi 4

Ein NAS selber zu bauen ist Dank dem Gigabit-LAN des Raspberry Pi 4 super einfach.
Als Software hat sich OpenMediaVault bewährt, auch wenn ich bei meinem ersten Test lediglich eine Schreibrate von 12.5 MB/s hatte, also scheinbar limitiert auf 100Mbit. Eine Vermutung war ein Bug mit Flash-Speicher. Um dies zu verifizieren, installiere ich OMV einmal neu.

 

Vorbereitung

Dazu schreibe ich erst einmal Raspbian Buster Lite auf eine SD-Karte.
Ich nutze dazu das Windows-Tool Win32DiskImager.
Nachdem das Image erfolgreich auf die SD-Karte geschrieben wurde, erstelle ich eine Datei auf der Root-Partition, welche sich ssh nennt (ohne Dateiendung). Damit hat man direkt beim ersten Boot des Raspis SSH-Zugriff.

Nachdem ich auf meiner FritzBox geprüft habe, welche IP-Adresse das Raspberry bekommen hat, logge ich mich per Putty über SSH ein.

Der erste Schritt sollte immer das Ändern des Standard-Passworts sein:

passwd 

Anschließend empfiehlt es sich, Software und Firmware zu aktualisieren:

sudo apt update && sudo apt upgrade 

Anschließend ein reboot, denn der tut immer gut:

sudo reboot 

 

Installation

Es gibt einen simplen Befehl, um OMV zu installieren. Dies kann einige Minuten dauern:

wget -O - https://github.com/OpenMediaVault-Plugin-Developers/installScript/raw/master/install | sudo bash 

Ist das Setup erfolgreich durchgelaufen, sollte dies so aussehen:

Wie empfohlen, starte ich das Raspi neu

sudo reboot 

Einrichtung

Zeit für den ersten Login in OMV. Dazu die IP des Raspis im Browser öffnen.
Standardmäßig lauten die Zugangsdaten “admin” mit dem Passwort “openmediavault”.

Schnell das Standard-Passwort ändern:

Wie bereits erwähnt, möchte ich prüfen, ob die geringe Übertragungsrate am Flashspeicher lag (ich habe dazu mal irgendwo einen Forenbeitrag gelesen).
Also schließe ich nun eine HDD per USB3 an.

Anschließend muss das Dateisystem für die Festplatte angelegt und eingebunden werden.
Die Einstellung muss jetzt übernommen werden. Dies kann 30 Sekunden dauern. Sollte es länger als eine Minute dauern, stimmt etwas nicht. Auch diesen Fehler hatte ich mit meiner ersten Installation. Jetzt funktioniert es [“Ha! Hat sich ja schon gelohnt.”].

Jetzt lege ich noch eben einen Benutzer an

wieder speichern

SMB aktivieren

eine Freigabe hinzufügen

und Einstellungen speichern.

Es folgt ein wichtiger Punkt, den ich gerne vergesse und mich dann wundere, weshalb mir keine Freigaben angezeigt werden. Denn auch, wenn der Punkt “Freigegebene Ordner” heißt, bedeutet dies nicht, dass die hier angelegten Ordner auch direkt freigegeben sind.

Wir gehen also nochmal zum SMB/CIFS Dienste und dort auf “Freigaben”

 

Speichern und Einstellungen anwenden.

Nun taucht die Freigabe auch im Windows-Explorer auf 🙂

Test

So, dann schiebe ich mal ein File auf das DIY-NAS

JA MAN!!!! Voller Uploadspeed!
Es liegt also tatsächlich am Flashspeicher (sowohl SSD, als auch USB-Stick getestet).

0 0 vote
Article Rating

Dominic

Dominic hat 2012 als Jahrgangsbester die Ausbildung zum Informatik-Kaufmann abgeschlossen und ist seit dem als Systemadministrator und IT-Supporter tätigt. Sein erstes Netzwerk baute er mit 13 Jahren auf, um eine LAN-Party zu hosten. Seit dem ist IT für ihn eine Lebenseinstellung.

ähnliche Beiträge

guest
2 Comments
Inline Feedbacks
View all comments
trackback
Stressberry - Ein empirischer Raspberry Pi Hitzecheck - DomBlox
8 Monate zuvor

[…] Um diesen Test durchzuführen, werde ich Stressberry auf einem Raspberry Pi 4 installieren. Ich nehme hierzu meine OMV-Installation aus diesem Beitrag. […]

trackback
Raspberry Pi 4 USB3 geringe Übertragungsrate - DomBlox
8 Monate zuvor

[…] meinem Beitrag zur Installation von Open Media Vault habe ich erwähnt, dass die Übertragungsrate auf ein USB3 Flashdrive (USB-Stick, SSD) am Raspberry […]